AnsweredAssumed Answered

Installing activiti 5.9/5.10

Question asked by jbbond on Jan 28, 2013
Latest reply on Jan 30, 2013 by trademak
Hi,

I am trying to install Activiti 5.9 on a new machine in order to make some changes to an existing project developed in 5.9. However, I badly failed in doing so. I get the same problem even when I try installing 5.10. It seems that ant demo.start fails to download tomcat. I also tried this on a different machine but same problem.

I would really appreciate if some one could help me

demo.install:

internal.cfg.create:
     [copy] Copying 1 file to \Activiti engine\activiti-5.9\setup\build\activiti-cfg
      [zip] Building zip: \Activiti engine\activiti-5.9\setup\build\activiti-cfg.jar
     [echo] copying configuration to ../workspace/activiti-engine-examples/src/main/config
    [unzip] Expanding: \Activiti engine\activiti-5.9\setup\build\activiti-cfg.jar into C:\Activiti engine\activiti-5.9\workspace\activiti-engin
e-examples\src\main\config

internal.classpath.libs:

internal.taskdef.launch:

h2.start:
     [echo] starting H2 database…
   [launch] launching cmd 'C:\Activiti engine\activiti-5.9\apps\h2\h2.start.bat ' in dir 'C:\Activiti engine\activiti-5.9\apps\h2'
   [launch] waiting for launch completion msg 'TCP server running on'…
   [launch]   Exception in thread "main" org.h2.jdbc.JdbcSQLException: Exception opening port "9092" (port may be in use), cause: "java.net.BindE
xception: Address already in use: JVM_Bind" [90061-132]
   [launch]     at org.h2.message.DbException.getJdbcSQLException(DbException.java:316)
   [launch]     at org.h2.message.DbException.get(DbException.java:156)
   [launch]     at org.h2.util.NetUtils.createServerSocketTry(NetUtils.java:175)
   [launch]     at org.h2.util.NetUtils.createServerSocket(NetUtils.java:141)
   [launch]     at org.h2.server.TcpServer.start(TcpServer.java:200)
   [launch]     at org.h2.tools.Server.start(Server.java:330)
   [launch]     at org.h2.tools.Server.runTool(Server.java:216)
   [launch]     at org.h2.tools.Server.main(Server.java:106)
   [launch]   Caused by: java.net.BindException: Address already in use: JVM_Bind
   [launch]     at java.net.DualStackPlainSocketImpl.bind0(Native Method)
   [launch]     at java.net.DualStackPlainSocketImpl.socketBind(Unknown Source)
   [launch]     at java.net.AbstractPlainSocketImpl.bind(Unknown Source)
   [launch]     at java.net.PlainSocketImpl.bind(Unknown Source)
   [launch]     at java.net.ServerSocket.bind(Unknown Source)
   [launch]     at java.net.ServerSocket.<init>(Unknown Source)
   [launch]     at java.net.ServerSocket.<init>(Unknown Source)
   [launch]     at org.h2.util.NetUtils.createServerSocketTry(NetUtils.java:171)
   [launch]     … 5 more
   [launch] launched process completed
     [echo] H2 database started

tomcat.start:

BUILD FAILED
\Activiti engine\activiti-5.9\setup\build.xml:330: couldn't find executable for script \activiti engine\activiti-5.9\apps\apache-tomcat-6.0.32\bin\startup

Outcomes