AnsweredAssumed Answered

Activiti 5.12 deployment

Question asked by lixkid on Apr 30, 2013
Latest reply on May 2, 2013 by lixkid
Hi,

I have successfuly implemented an application which utilized Activiti Engine 5.11 (and Activiti CDI module). Recently I tried to upgrade Activiti Engine to version 5.12.1 (and before that to 5.12) and to new version of the Activiti CDI module (if there has been one recently). But, during deployment (on Glassfish) an error occurs with the following message:

Error occurred during deployment: Exception while loading the app : WELD-001408 Unsatisfied dependencies for type [ContextAssociationManager] with qualifiers [@Default] at injection point [[field] @Inject private org.activiti.cdi.BusinessProcess.associationManager]. Please see server.log for more details.

Is this known issues while trying to deploy an application with Activiti Engine 5.12? I've tried to resolve an issue by combining activiti-engine-5.12.1.jar with activiti-cdi.jar from previous releases (assuming that problem is caused by activiti-cdi.jar), but without success. Also, I haven't found similar problem reported by somebody else on the Web.

I would appreciate any help.

Thanks

Outcomes