AnsweredAssumed Answered

Getting exception when trying to connect to 5.12

Question asked by studious on May 1, 2013
Latest reply on May 2, 2013 by jbarrez
Hi,

I am getting the exception shown below
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
Exception in thread "main" java.lang.NoClassDefFoundError: org/activiti/bpmn/model/Task
   at org.activiti.engine.impl.cfg.ProcessEngineConfigurationImpl.getDefaultDeployers(ProcessEngineConfigurationImpl.java:768)
   at org.activiti.engine.impl.cfg.ProcessEngineConfigurationImpl.initDeployers(ProcessEngineConfigurationImpl.java:721)
   at org.activiti.engine.impl.cfg.ProcessEngineConfigurationImpl.init(ProcessEngineConfigurationImpl.java:393)
   at org.activiti.engine.impl.cfg.ProcessEngineConfigurationImpl.buildProcessEngine(ProcessEngineConfigurationImpl.java:373)
   at com.up.procreport2.rest.MainRep.main(MainRep.java:70)
Caused by: java.lang.ClassNotFoundException: org.activiti.bpmn.model.Task
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)

I did try with 5.11 it is working fine. But when I tried to include 5.12 jars it is giving the error
at             ProcessEngine processEngine = ProcessEngineConfiguration
                  .createProcessEngineConfigurationFromResource("resource/activiti.cfg.xml")
                  .buildProcessEngine();
Tried with 5.12.1 , still seeing the error. Did anyone face the same problem before?

Outcomes