AnsweredAssumed Answered

Exclusive Gateway has no outgoing sequence flows - Activiti 5.12 upgrade

Question asked by dp on May 14, 2013
Latest reply on May 16, 2013 by trademak
Hi,

We have a workflow with subprocesses and multiple exclusive gateways.
We upgraded the activiti from 5.10 to 5.12. After the upgrade our test failed with the following error:
Exclusive Gateway 'gatewayAAA' has no outgoing sequence flows. | gatewayAAA | line 176 | column 9

   at org.activiti.engine.impl.bpmn.parser.BpmnParse.execute(BpmnParse.java:198)
   at org.activiti.engine.impl.bpmn.deployer.BpmnDeployer.deploy(BpmnDeployer.java:86)
   at org.activiti.engine.impl.persistence.deploy.DeploymentManager.deploy(DeploymentManager.java:42)
   at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:68)
   at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:33)
   at org.activiti.engine.impl.interceptor.CommandExecutorImpl.execute(CommandExecutorImpl.java:24)
   at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(CommandContextInterceptor.java:61)
   at org.activiti.spring.SpringTransactionInterceptor$1.doInTransaction(SpringTransactionInterceptor.java:42)
   at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:130)
   at org.activiti.spring.SpringTransactionInterceptor.execute(SpringTransactionInterceptor.java:40)
   at org.activiti.engine.impl.interceptor.LogInterceptor.execute(LogInterceptor.java:31)
   at org.activiti.engine.impl.RepositoryServiceImpl.deploy(RepositoryServiceImpl.java:70)
   at org.activiti.engine.impl.repository.DeploymentBuilderImpl.deploy(DeploymentBuilderImpl.java:134)
   at org.activiti.spring.SpringProcessEngineConfiguration.autoDeployResources(SpringProcessEngineConfiguration.java:148)
   at org.activiti.spring.SpringProcessEngineConfiguration.buildProcessEngine(SpringProcessEngineConfiguration.java:65)
   at org.activiti.spring.ProcessEngineFactoryBean.getObject(ProcessEngineFactoryBean.java:56)
   at org.activiti.spring.ProcessEngineFactoryBean.getObject(ProcessEngineFactoryBean.java:32)
   at org.springframework.beans.factory.support.FactoryBeanRegistrySupport.doGetObjectFromFactoryBean(FactoryBeanRegistrySupport.java:142)
   … 57 more


Examining the xml for the process definition we saw that the sequence flows definitions are described outside of the sub process element (even if they are part of that subprocess).
We fixed the XML by moving the sequence flows definitions inside the sub process and after that the tests passed. But, as soon as we change something using the activiti designer(eclipse plugin 5.12), the XML is regenerated and the problem reappears.

Thank you!

Outcomes