AnsweredAssumed Answered

Deployment of Web service process failed in Activity-Explorer 5.13

Question asked by perpetuum_mobile on Jul 8, 2013
Latest reply on Jul 10, 2013 by frederikheremans1
Hello!
I have a problem with deployment of process containing a web service task
(in explorer: 'Manage'->'Deployments'->'Upload new')
I've got this error:

08.07.2013 15:11:18 com.vaadin.Application terminalError
SEVERE: Terminal error:
com.vaadin.event.ListenerMethod$MethodException: Invocation of method uploadFinished in org.activiti.explorer.ui.custom.UploadComponent failed.
   at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:530)
   at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:164)
   at com.vaadin.ui.AbstractComponent.fireEvent(AbstractComponent.java:1219)
   at com.vaadin.ui.Upload.fireUploadInterrupted(Upload.java:731)
   at com.vaadin.ui.Upload$1.streamingFailed(Upload.java:1037)
   at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.streamToReceiver(AbstractCommunicationManager.java:619)
   at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.doHandleSimpleMultipartFileUpload(AbstractCommunicationManager.java:476)
   at com.vaadin.terminal.gwt.server.CommunicationManager.handleFileUpload(CommunicationManager.java:259)
   at com.vaadin.terminal.gwt.server.AbstractApplicationServlet.service(AbstractApplicationServlet.java:495)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
   at org.activiti.explorer.filter.ExplorerFilter.doFilter(ExplorerFilter.java:44)
   at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
   at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
   at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
   at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
   at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
   at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
   at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
   at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:953)
   at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
   at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
   at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1023)
   at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
   at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:312)
   at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
   at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.NullPointerException
   at org.activiti.explorer.ui.management.deployment.DeploymentUploadReceiver.showUploadedDeployment(DeploymentUploadReceiver.java:114)
   at org.activiti.explorer.ui.management.deployment.DeploymentUploadReceiver.uploadFinished(DeploymentUploadReceiver.java:73)
   at org.activiti.explorer.ui.custom.UploadComponent.uploadFinished(UploadComponent.java:173)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
   … 28 more


I have Activiti CXF module in classpath, and I have my WS running at certain URL.
Here is my process description:

<?xml version="1.0" encoding="UTF-8"?>
<definitions xmlns="http://www.omg.org/spec/BPMN/20100524/MODEL"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xmlns:activiti="http://activiti.org/bpmn"
           xmlns:bpmndi="http://www.omg.org/spec/BPMN/20100524/DI"
           xmlns:omgdc="http://www.omg.org/spec/DD/20100524/DC"
           xmlns:omgdi="http://www.omg.org/spec/DD/20100524/DI"
           typeLanguage="http://www.w3.org/2001/XMLSchema"
           expressionLanguage="http://www.w3.org/1999/XPath"
           targetNamespace="org.activiti.enginge.impl.webservice"
           xmlns:tns="org.activiti.enginge.impl.webservice"
           xmlns:hello="http://hello.srv.ws.cnv.com/">
          
  <import importType="http://schemas.xmlsoap.org/wsdl/"
        location="http://localhost:9080/WS/hello?wsdl"
        namespace="http://hello.srv.ws.cnv.com/'/>
 
  <!– Interface: implementationRef = QName of WSDL Port Type –>
   <interface name="hello Interface" implementationRef="hello:Hello">
      <!– Operation: implementationRef = QName of WSDL Operation –>
      <operation id="sayHelloOperation" name="say hello Operation" implementationRef="hello:sayHello">
         <inMessageRef>tns:sayHelloRequestMessage</inMessageRef>
      </operation>
   </interface>
   <message id="sayHelloRequestMessage" itemRef="tns:sayHelloRequestItem" />
   <itemDefinition id="sayHelloRequestItem" structureRef="hello:sayHello" /><!– QName of input element –>
     
  <process id="specProcess" name="Spec process" isExecutable="true">
     <dataObject id="dataInputOfProcess" name="Input for webservice" itemSubjectRef="tns:sayHelloRequestItem"/>
 
    <startEvent id="startevent1" name="Start"></startEvent>
    <endEvent id="endevent1" name="End"></endEvent>
   
    <scriptTask id="scripttask1" name="Script Task" scriptFormat="groovy">
       <script>
          def scriptVar = "Hello"
          execution.setVariable("dataInputOfProcess", scriptVar)
        </script>
    </scriptTask>
    <serviceTask id="webService" name="WSTask" implementation="##WebService" operationRef="tns:sayHelloOperation">
       <!– The BPMN 2.0 Meta Model requires an Input/Output Specification –>
      <ioSpecification>
         <dataInput itemSubjectRef="tns:sayHelloRequestItem" id="dataInputOfServiceTask" />
         <inputSet>
            <dataInputRefs>dataInputOfServiceTask</dataInputRefs>
         </inputSet>
         <outputSet />
      </ioSpecification>
      <dataInputAssociation>
         <sourceRef>dataInputOfProcess</sourceRef>
         <targetRef>dataInputOfServiceTask</targetRef>
         <assignment>
            <from>${dataInputOfProcess}</from>
            <to>${dataInputOfServiceTask.value}</to>
         </assignment>
      </dataInputAssociation>
    </serviceTask>
    <receiveTask id="receivetask1" name="Receive Task"></receiveTask>
    <sequenceFlow id="flow1" sourceRef="startevent1" targetRef="scripttask1"></sequenceFlow>
    <sequenceFlow id="flow2" sourceRef="scripttask1" targetRef="webService"></sequenceFlow>
    <sequenceFlow id="flow3" sourceRef="webService" targetRef="receivetask1"></sequenceFlow>
    <sequenceFlow id="flow4" sourceRef="receivetask1" targetRef="endevent1"></sequenceFlow>
  </process>
</definitions>


So, I got mentioned error trying to deploy this process.
Then I wanted to deploy very simple bpmn including only WSDL import:

<?xml version="1.0" encoding="UTF-8"?>
<definitions xmlns="http://www.omg.org/spec/BPMN/20100524/MODEL"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xmlns:activiti="http://activiti.org/bpmn"
           xmlns:bpmndi="http://www.omg.org/spec/BPMN/20100524/DI"
           xmlns:omgdc="http://www.omg.org/spec/DD/20100524/DC"
           xmlns:omgdi="http://www.omg.org/spec/DD/20100524/DI"
           typeLanguage="http://www.w3.org/2001/XMLSchema"
           expressionLanguage="http://www.w3.org/1999/XPath"
           targetNamespace="org.activiti.enginge.impl.webservice"
           xmlns:tns="org.activiti.enginge.impl.webservice"
           xmlns:hello="http://hello.srv.ws.cnv.com/">
          
  <import importType="http://schemas.xmlsoap.org/wsdl/"
        location="http://localhost:9080/WS/hello?wsdl"
        namespace="http://hello.srv.ws.cnv.com/" />
  <process id="specProcess" name="Spec process" isExecutable="true">
    <startEvent id="startevent1" name="Start"></startEvent>
    <endEvent id="endevent1" name="End"></endEvent>
    <sequenceFlow id="flow1" sourceRef="startevent1" targetRef="usertask1"></sequenceFlow>
    <sequenceFlow id="flow2" sourceRef="usertask1" targetRef="endevent1"></sequenceFlow>
    <userTask id="usertask1" name="WSTask"></userTask>
  </process>
</definitions>


But I've got the same error.
This old topic contains the similar problem's discussion, but I found no answer there.

Thank you.

Outcomes