AnsweredAssumed Answered

Rest Query 415

Question asked by atcevik on Aug 15, 2013
Latest reply on Feb 12, 2014 by trademak
Hello there,

Been using activiti using rest services for a while, and while trying to add features related to query services to the application, which I did not send data to previously, I keep on getting http 415.

I use post while creating process-instances etc, no problem. And all my other requests work well.

Tried the process-instances and tasks, both presenting the same result as (guess from restlet)

{
    "errorMessage": "Unsupported Media Type",
    "statusCode": 415
}

my request headers :

POST /gipsy.web/service/query/process-instances HTTP/1.1
Host: localhost:8088
Connection: keep-alive
Content-Length: 10
Cache-Control: no-cache
Origin: chrome-extension://fdmmgilgnpjigdojojpjoooidkmcomcm
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36
Content-Type: application/json
Accept: */*
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,en;q=0.8

the form data I am sending is
{"id":201}

Any ideas  ? I am stuck here.

P.S. Running on a tomcat7, ubuntu server, if it matters.

Outcomes