AnsweredAssumed Answered

Activiti Explorer fails due the inability to upgrade Activiti DB schema version

Question asked by ambharath on Sep 20, 2013
Latest reply on Sep 23, 2013 by ambharath
Hello All,

I am newbie in terms of Activiti Development…owing to the many advantages of this framework, I chose this as my BPM framework…

Whilst starting with the basics, I ran into the following query:

In activiti-explorer (ver 5.13), inside the activiti-engine-5.13 jar file, I don't see any upgrade (engine) scripts from version 5.11 to 5.12 & 5.12 to 5.13…eg: activiti.h2.upgradestep.511.to.512.engine & activiti.h2.upgradestep.512.to.513.engine are not to be found… is this an expected omission? If so, what is the work-around (other than the one mentioned by tiesebarrell) since I assume that whenever the activiti-explorer .war starts up (I am using Tomcat 7.0.42), it tries to upgrade the schema (when necessary, i.e., in case the schema version is older or lesser than the version of activiti-explorer)… I am using h2 database (ver 1.3.173)…

Can anyone please help!

Regards,
A M Bharath, new Activiti developer

Outcomes