AnsweredAssumed Answered

How to configure activiti-explorer for SSO?

Question asked by tombo on Sep 23, 2013
Latest reply on Oct 2, 2013 by frederikheremans1
I have activiti-explorer 5.13 deployed at the weblogic 10.3.6. application server with kerberos SPNEGO authentication and authorization against Active Directory (like this example:  http://biemond.blogspot.com/2011/08/single-sign-on-with-windows-kerberos-on.html ).

To obtain SSO, usual method is to set web.xml  login-config:


<login-config>
    <auth-method>CLIENT-CERT</auth-method>
</login-config>


It seems that activiti-explorer is ignoring this parameter as login page appears but it is enough to enter just user name and press login button and user will be authenticated (this confirms that kerberos authentication works). It’s the same whether this login-conf parameter is present or not in the web.xml.

I was unable to find any information regarding this matter, so any help would be appreciated.

Boris

Outcomes