AnsweredAssumed Answered

Avoid generating demodata in rest-webapp

Question asked by b.schnarr on Dec 19, 2013
Latest reply on Feb 17, 2014 by m.koohi.m
Hello at all,

I have the following deployment:

One MySQL-Database for both instances (activiti-rest.war and activiti-explorer.war). Database name is activiti.
First, I deployed the activiti-rest.war. After that, I configured the database like this in


After that, I copied the mysql-connector-java-5.1.27-bin.jar in the corresponding lib-Folder. In addition, I disabled the generation of demodata for the rest webapp in the activiti-context:

   <bean id="demoDataGenerator" class=""
      <property name="processEngine" ref="processEngine" />
      <property name="createDemoUsersAndGroups" value="false" />
        <property name="createDemoProcessDefinitions" value="false" />
        <property name="createDemoModels" value="false" />

After that, I deployed the activiti-explorer.war, pointing to the same db. I changed to the same code as above. After that, I copied the MySQl-Connector in the lib-Folder. I did NOT change the generation of demodata. Therefore, the explorer will generate demodata.

After the deployment, everything works fine, I have no tasks. The explorer is empty except of the demodata.
After I did one REST-Call for testing, e.g.  get-Request to : http://ip-address:8080/activiti-rest/service/identity/users, the activiti explorer is full of tasks in inbox, Queue, Involved etc (see picture: In the middle of explorer, there is the message: Warning: userid is null. All tasks are discribed with lorem ipsun text.

Why does this happen? I explicitely disabled the generation of demodata in the rest webapp. But after the first rest-call, the explorer looks like the picture. Any ideas?

Thank you very much for your help