AnsweredAssumed Answered

Upgrade from 5.14 to 5.15 - MySql Error

Question asked by koallen on Mar 22, 2014
Latest reply on Mar 24, 2014 by koallen
We are running on Activiti 5.14 with Mysql 5.6.14 community version.

Running the upgrade scripts generates the error below,:

07:43:48,940 ERROR DbSqlSession : 993 - problem during schema upgrade, statement ALTER TABLE ACT_RU_JOB CHANGE LOCK_EXP_TIME_TEMP_ LOCK_EXP_TIME_ timestamp(3)
com.mysql.jdbc.MysqlDataTruncation: Data truncation: Invalid use of NULL value
   at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:4235)
   at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:4169)
   at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2617)
   at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2778)
   at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2819)
   at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2768)
   at com.mysql.jdbc.StatementImpl.execute(StatementImpl.java:894)
   at com.mysql.jdbc.StatementImpl.execute(StatementImpl.java:732)

Outcomes