AnsweredAssumed Answered

diagram viewer - process instance wise diagram - throws null pointer

Question asked by badrisudheer on Jun 3, 2014
Latest reply on Sep 25, 2014 by gregdavisfromnj
I have tried to use diagram viewer index html page to see the diagram for a given process instance created for a process definition using (…/diagram-viewer/index.html?processDefinitionId=<proc-def-id>&processInstanceId=<proc-instance-id> ). It worked well, meaning showed the path of execution flow in RED as long as the process instance is not ended. But, once the process instance is ended, it shows the diagram but, could not redraw (or highlight) the flow in RED. Looking at the logs, it threw NullPointerException  -here is the error log snippet -

java.lang.NullPointerException
   at org.activiti.rest.diagram.services.ProcessInstanceHighlightsResource.getHighlighted(ProcessInstanceHighlightsResource.java:53)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

Thought of checking on the forum to see if there is anything specific I am supposed to do to get the flow path redrawn successfully after the process instance execution ends. Any idea ?

Outcomes