AnsweredAssumed Answered

'Invalid reference in diagram interchange definition' errors during unit test

Question asked by viggo.navarsete on Jul 7, 2014
Latest reply on Jul 9, 2014 by trademak
Hi, I've made a process in Modeler and exported it to an XML file and tries to load it in a unit test, and I get the following output which I have a hard time to understand what to do about:

2014-07-07 22:17:06,571 [main] WARN   - Following warnings encountered during process validation: [Validation set: 'activiti-executable-process' | Problem: 'activiti-di-invalid-reference'] : Invalid reference in diagram interchange definition: could not find chain101Pool - [Extra info : ]
[Validation set: 'activiti-executable-process' | Problem: 'activiti-di-invalid-reference'] : Invalid reference in diagram interchange definition: could not find wholesalerLane - [Extra info : ]
[Validation set: 'activiti-executable-process' | Problem: 'activiti-di-invalid-reference'] : Invalid reference in diagram interchange definition: could not find supplierLane - [Extra info : ]
[Validation set: 'activiti-executable-process' | Problem: 'activiti-di-invalid-reference'] : Invalid reference in diagram interchange definition: could not find transporterLane - [Extra info : ]

2014-07-07 22:17:06,601 [main] WARN   - Invalid reference in diagram interchange definition: could not find chain101Pool
2014-07-07 22:17:06,601 [main] WARN   - Invalid reference in diagram interchange definition: could not find wholesalerLane
2014-07-07 22:17:06,602 [main] WARN   - Invalid reference in diagram interchange definition: could not find supplierLane
2014-07-07 22:17:06,602 [main] WARN   - Invalid reference in diagram interchange definition: could not find transporterLane

Here is a pastie of the process definition that might help narrowing down this issue with me: http://pastie.org/private/cmrtkbmgox1k6w5uuqmq

Thanks in advance.

Viggo

Outcomes