AnsweredAssumed Answered

activiti-standalone-context.xml is not exist.

Question asked by harishp on Dec 6, 2014
Latest reply on Jun 20, 2016 by jbarrez
1. I did download activiti-5.16.4.zip and extracted in a folder. 
2. Tomcat7 and  java version "1.7.0_45" version is present, I copied  "activiti-explorer.war" to the webapps directory of Tomcat.
3. Restarted the tomcat7 service by using "sudo service tomcat7 restart" successfully.
4. Able load the  url:  http://localhost:8080/activiti-explorer .
5. Did login using kermit username.
6. Copied …./wars/activiti-explorer.war  and … /wars/activiti-rest.war to webapps folder of tomcat installation.

As we know Activiti Explorer runs an in-memory H2 database by default.  To disable this, the " activiti-standalone-context.xml"  file in the WEB-INF folder should be changed.  We need to add the following snippet to the  "activiti-standalone-context.xml" file. But the problem is that there is no "activiti-standalone-context.xml" file.

<bean id="demoDataGenerator" class="org.activiti.explorer.demo.DemoDataGenerator">
        <property name="processEngine" ref="processEngine" / >
        <property name="createDemoUsersAndGroups" value="false" />
        <property name="createDemoProcessDefinitions" value="false" />
        <property name="createDemoModels" value="false" />
      </bean>

Please let me know, how to fix this issue.
Thank you,
Hari..

Outcomes