AnsweredAssumed Answered

Unable to find BPMN20.xsd

Question asked by yadavan88 on Mar 17, 2015
Latest reply on Mar 19, 2015 by yvoswillens
I am having an application developed in scala. I am using activiti engine in that application.
Activiti Version : 5.17.0
Scala : 2.11

I have created an executable jar file of my application(using sbt-one-jar). I am able to deploy the process successfully, but after the deployment it is not generating the process definition id. Between deployment and generation of process definition, I am getting the following error in the EventListener.

ERROR c.r.w.c.a.WorkflowServiceSupervisor - Recreating dead budget instance, cause org.xml.sax.SAXParseException; schema_reference.4: Failed to read schema document 'jar:file:/workflow-api_2.11-0.1-SNAPSHOT-one-jar.jar!/lib/activiti-bpmn-converter-5.17.0.jar!/org/activiti/impl/bpmn/parser/BPMN20.xsd', because
1) could not find thedocument;
2) the document could not be read;
3) the root element of the document is not <xsd:schema>., message

Everything is working fine if I run it in local, however, once I run from the jar file, I get the above issue. Can anyone help me to fix this?

My jar file structure is :
myapp-one-jar.jar
           |
           myapp.jar
                     |
                     lib
                         activiti-bpmn-converter.jar
                                                                 |
                                                                 BPMN20.xsd
                                                                 BP…xml

Outcomes