AnsweredAssumed Answered

Activiti Engine not picking up properties from activiti.cfg.xml

Question asked by shil-srini on Jun 2, 2015
Latest reply on Jun 11, 2015 by jbarrez
Hi there,

I'm New to Activiti and Started with the local deployment of activiti after downloading the source. I'm trying out a simple task where a mail can be sent on some condition. I've changed the activiti.cfg.xml in activiti-engine\src\test\resources, It is still taking the default java mail configuration and throwing an error stating mail cannot be sent to localhost port 25.
I've made the following changes in the file activiti-engine\src\test\resources\activiti.cfg.xml:

<bean id="processEngineConfiguration"
    class="org.activiti.engine.impl.cfg.StandaloneProcessEngineConfiguration">
   
    <property name="mailServerHost" value="smtp.gmail.com" />
         <property name="mailServerPort" value="587" />
         <property name="mailServerDefaultFrom" value="xxxx@gmail.com" />
         <property name="mailServerUsername" value="xxxx@gmail.com" />
         <property name="mailServerPassword" value="******" />
          <property name="mailServerUseTLS" value="true" />
          <property name="history" value="full" />
</bean>

I've found a workaround where I modify the engine.properties for mail server settings and the changes are reflected. Though the mailserver changes are reflecting there I'm facing an issue where the useTLS property cannot be set there. :(

Could anybody please help?

Thanks.


Outcomes