AnsweredAssumed Answered

mail server settings for activiti explorer

Question asked by gurolakman on Aug 24, 2015
Latest reply on Aug 26, 2015 by vasile.dirla
I created a simple flow comprising a single "send mail task" under Eclipse and tested its behavior successfully after configuring the mail server properties in an associated <activiti.cfg.xml> file as follows:

<property name="mailServerHost" value="smtp.gmail.com" />
<property name="mailServerPort" value="465" />
<property name="mailServerUsername" value="…" />
<property name="mailServerPassword" value="…" />
<property name="mailServerUseSSL" value="true" />

I then deployed the same flow on the activiti explorer (portal), configured the <engine.properties> file for activiti-explorer as follows, and wanted to test its behavior once again (i.e., by starting the flow manually from the portal).

engine.email.enabled=true
engine.email.host=smtp.gmail.com
engine.email.port=465
engine.email.username=…
engine.email.password=…
engine.email.usessl=true

Unfortunately, I failed to get my flow to work properly (i.e., the email send attempt to smtp.gmail.com:465 timed out).

I'm wondering if this failure may be triggered by the "engine.email.usessl" property setting above and whether the property name is valid. I wasn't able to find a comprehensive list of valid <engine.email.*> properties in the user guide.

Any insight will be greatly appreciated.

Outcomes