AnsweredAssumed Answered

Oracle Start/Deploy Error

Question asked by macalase on Oct 30, 2015
Latest reply on Nov 2, 2015 by vasile.dirla
Hi All,

We are getting the error below in one of our applications, its when we redeploy the application with activiti embedded in it.
Its with Activiti 5.18.0, Oracle RAC 11.2.0.3.1, Spring 4.2.1, and Websphere 8.5.5.5


<blockcode>
### Error updating database.  Cause: java.sql.SQLException: ORA-00600: internal error code, arguments: [koklGetLocAndFlag1], [], [], [], [], [], [], [], [], [], [], []

### The error may involve org.activiti.engine.impl.persistence.entity.ResourceEntity.bulkInsertResource_oracle-Inline
### The error occurred while setting parameters
### SQL: INSERT ALL                   INTO ACT_GE_BYTEARRAY(ID_, REV_, NAME_, BYTES_, DEPLOYMENT_ID_, GENERATED_) VALUES          (?,          1,          ?,          ?,          ?,          ?)                   INTO ACT_GE_BYTEARRAY(ID_, REV_, NAME_, BYTES_, DEPLOYMENT_ID_, GENERATED_) VALUES          (?,          1,          ?,          ?,          ?,          ?)             SELECT * FROM dual
### Cause: java.sql.SQLException: ORA-00600: internal error code, arguments: [koklGetLocAndFlag1], [], [], [], [], [], [], [], [], [], [], []

        at org.springframework.context.annotation.CommonAnnotationBeanPostProcessor.postProcessPropertyValues(CommonAnnotationBeanPostProcessor.java:311)
        at
</blockcode>

I'm not sure how to fix it yet, I looked at http://www.orafaq.com/wiki/ORA-00600 and I might try replacing the sqls with
"SELECT * FROM sys.dual"

Anybody seen this one before I try anything?

Regards,
Mac





Outcomes