AnsweredAssumed Answered

activiti-rest HTTP 404 on Weblogic 12.1.3

Question asked by espe on Nov 5, 2015
Latest reply on Nov 5, 2015 by espe
Hello,

I'm on Windows platform. Downloaded activiti-rest 5.17, deployed it and while I'm trying to make some test calls I get only an HTTP 404 as a response. I read the user guide and some sample calls that I tried are (using either soap-ui or chrome extension):

http://localhost:7101/activiti-rest/service/deployments
http://localhost:7101/activiti-rest/repository/deployments
http://localhost:7101/activiti-rest/repository/process-definitions

All of them with all the possible combinations. GET, POST with Basic Auth, without Basic Auth, with credentials (kermit:kermit@localhost:7101), without credentials.

All I get is Error 404–Not Found (which comes from the server, not Activiti).
In the logs I notice the following:
<Nov 5, 2015 12:45:57 PM EET> <Warning> <Socket> <BEA-000449> <Closing the socket, as no data read from it on 127.0.0.1:60.832 during the configured idle timeout of 5 seconds.>
<org.springframework.web.servlet.DispatcherServlet> <DispatcherServlet> <noHandlerFound> <No mapping found for HTTP request with URI [/activiti-rest/service/deployments] in DispatcherServlet with name 'dispatcher'>

DB configuration is fine because activiti-explorer works perfectly (and I copy-paste the configuration). Server is up and running normally (as i said, activit-explorer runs like a charm).

Any ideas?

Thanks for your support and the great job you're doing

Outcomes