AnsweredAssumed Answered

ACT_ID_USER table is empty

Question asked by seema on Dec 30, 2015
Latest reply on Jan 7, 2016 by jbarrez
I have integrated activiti-explorer and OpenLDAP. I created users in OpenLDAP and i am able to login in activiti-explorer using OpenLDAP's users but ACT_ID_USER table in activiti-explorer is empty. How to store users in ACT_ID_USER table. Here is my configuration:
<property name="configurators">
      <list>
              <bean class="org.activiti.ldap.LDAPConfigurator">

                <!– Server connection params –>
                <property name="server" value="ldap://localhost" />
                <property name="port" value="389" />
                <property name="user" value="cn=admin,dc=test,dc=com" />
                <property name="password" value="secret" />

                <!– Query params –>
                <property name="baseDn" value="dc=test,dc=com" />
                <property name="queryUserByUserId" value="(&amp;(objectClass=inetOrgPerson)(mail={0}))" />
                <property name="queryUserByFullNameLike" value="(&amp;(objectClass=inetOrgPerson)(|({0}=*{1}*)({2}=*{3}*)))" />
                <property name="queryGroupsForUser" value="(&amp;(objectClass=group)(member={0}))" />

                <!– Only for Active Directories –>
                <property name="customConnectionParameters">
                <map>
                <entry key="InitialDirContext" value="Context.REFERRAL" />
                </map>
                </property>

                <!– Attribute config –>
                <property name="userIdAttribute" value="mail" />
                <property name="userFirstNameAttribute" value="givenName" />
                <property name="userLastNameAttribute" value="sn" />
      <property name="groupIdAttribute" value="gidnumber" />
                <property name="groupNameAttribute" value="cn" />

              </bean>
          </list>
        </property>

Please give some solution. Any help is appreciated.

Outcomes