AnsweredAssumed Answered

Activiti 5.19 + weblogic 12c

Question asked by praveen_j2 on Jan 29, 2016
Hi,

Downloaded activiti-5.19.0.zip and deployed the War files(Activiti-Explorer & Activiti Rest) in Tomcat webapps folder. Works Fine !!!!!

Deployed the same into Weblogic 12c server. Deployed successfully and when accessing activiti-exploere via Url getting the following error instead of the login form,

Error 500–Internal Server Error

java.lang.NullPointerException
   at weblogic.utils.StringUtils.split(StringUtils.java:58)
   at weblogic.servlet.internal.WebAppServletContext.isAbsoluteURL(WebAppServletContext.java:2389)
   at weblogic.servlet.internal.ServletResponseImpl.sendRedirect(ServletResponseImpl.java:924)
   at weblogic.servlet.internal.ServletResponseImpl.sendRedirect(ServletResponseImpl.java:918)
   at com.vaadin.terminal.gwt.server.AbstractApplicationServlet.handleServiceSessionExpired(AbstractApplicationServlet.java:1128)
   at com.vaadin.terminal.gwt.server.AbstractApplicationServlet.service(AbstractApplicationServlet.java:544)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:844)
   at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:280)
   at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:254)
   at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:136)
   at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:346)
   at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:25)
   at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:79)
   at org.activiti.explorer.filter.ExplorerFilter.doFilter(ExplorerFilter.java:53)
   at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:79)
   at weblogic.servlet.internal.RequestEventsFilter.doFilter(RequestEventsFilter.java:27)
   at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:79)
   at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3436)
   at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3402)
   at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
   at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
   at weblogic.servlet.provider.WlsSubjectHandle.run(WlsSubjectHandle.java:57)
   at weblogic.servlet.internal.WebAppServletContext.doSecuredExecute(WebAppServletContext.java:2285)
   at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2201)
   at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2179)
   at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1572)
   at weblogic.servlet.provider.ContainerSupportProviderImpl$WlsRequestExecutor.run(ContainerSupportProviderImpl.java:255)
   at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311)
   at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)

—————————————————————————————
Can see the activiti logo. Error is in the following Iframe -> <iframe width="100%" height="100%" frameborder="0" name="PID3" src="/activiti-explorer/ui/APP/2/login" allowtransparency="true">

—————————————————————————————

Following are the errors displayed in the console,

"NetworkError: 401 Unauthorized - http://localhost:7001/activiti-explorer/VAADIN/themes/reindeer/styles.css"
styles.css
"NetworkError: 401 Unauthorized - http://localhost:7001/activiti-explorer/ui/UIDL?repaintAll=1&sh=864&sw=1536&cw=1536&ch=539&vw=1536&vh=0&fr=&tzo=-330&rtzo=-330&dstd=0&dston=false&curdate=1454063512866&wsver=6.8.8"
UIDL?re…r=6.8.8
"NetworkError: 401 Unauthorized - http://localhost:7001/activiti-explorer/VAADIN/themes/base/common/img/loading-indicator.gif"
loading…tor.gif
"NetworkError: 401 Unauthorized - http://localhost:7001/activiti-explorer/VAADIN/themes/activiti/img/explorer-logo.png"
explorer-logo.png
"NetworkError: 401 Unauthorized - http://localhost:7001/activiti-explorer/ui/APP/2/login"
login
"NetworkError: 500 Internal Server Error - http://localhost:7001/activiti-explorer/ui/APP/2/login"


——————————————————————————————–

Could someone help. Thanks.

Outcomes