AnsweredAssumed Answered

'...Could not send e-mail...'

Question asked by forschungsstudentin on Mar 13, 2016
Latest reply on Mar 16, 2016 by forschungsstudentin
hello,

I use Activiti.6.0.0.Beta2, Apache Maven 3.3.3, Apache Tomcat 8.0.32 and jdk 1.8.0_45-b15.

My Settings:

- "db.properties":
  db=h2
  jdbc.driver=org.h2.Driver
  jdbc.url=jdbc:h2:file:activiti;DB_CLOSE_DELAY=1000
  jdbc.username=sa
  jdbc.password=

- "activiti-app.properties" and "activiti-app-dev.properties":
  email.enabled=true
  email.host=smtp.gmail.com
  email.port=587
  email.useCredentials=true
  email.username=master.activiti@gmail.com
  email.password=xxpassword
  # The base url that will be used to create urls in emails.
  #email.base.url=http://localhost:9999/activiti-app
  email.from.default=master.activiti@gmail.com
  email.from.default.name=Activiti
  email.feedback.default=master.activiti@gmail.com

- "activiti-custom-context.xml":
  <bean id="processEngineConfiguration" class="org.activiti.spring.SpringProcessEngineConfiguration">
  <property name="dataSource" ref="dataSource" />
  <property name="transactionManager" ref="transactionManager" />
  <property name="databaseSchemaUpdate" value="true" />
  <property name="jobExecutorActivate" value="true" />
  <property name="mailServerHost" value="smtp.gmail.com" />
  <property name="mailServerPort" value="587" />
  <property name="mailServerUseSSL" value="false" />
  <property name="mailServerUseTLS" value="true" />
  <property name="mailServerDefaultFrom" value="master.activiti@gmail.com" />
  <property name="mailServerUsername" value="master.activiti@gmail.com" />
  <property name="mailServerPassword" value="xxpassword" />
  …

- "engine.properties":
  engine.email.enabled=true
  engine.email.host=smtp.gmail.com

- "Kickstart" –> "Create Process"

- see attachment "Mail_erstellen.bpmn20.xml_.txt"

- "Kickstart" –> "Create App"

- "Deploy"

- "Start a process"

- Error Message "Sorry. an error occours" appears

-  see attachment "localhost-log_2016-03-12_23.59.txt"
…Could not send e-mail in execution 15004] with root cause…

Did I forgot something?

Thanks for help.

Regards,
Sabine

Outcomes