AnsweredAssumed Answered

NoSuchMethodError when using HistoryService

Question asked by amy11 on Apr 4, 2016
Latest reply on Apr 5, 2016 by amy11
Hi everybody,

working with Activiti 5.19.0.2 OSX, Tomcat 8.0.32 - I am trying to retrieve previous task informations using "HistoryService" resp. "HistoricTaskInstance" inside a TaskListener. My Unit test works fine but as soon as I run the process an interesting error msg. occurs which I apparently cannot get rid of:

 
Caused by: java.lang.NoSuchMethodError: org.activiti.engine.history.HistoricTaskInstanceQuery.processInstanceId(Ljava/lang/String;)Lorg/activiti/engine/history/HistoricTaskInstanceQuery;


AFAIK there seems to be a version related problem which I have also encountered while testing in Eclipse - those errors are all cleaned up in the eclipse environment. Still having the same error when running the process.

This is the code snippet that causes the trouble as if this is an out-of-date-way to query historic data…:

HistoricTaskInstance historicTask = historyService.createHistoricTaskInstanceQuery()
               .processInstanceId(delegateTask.getProcessInstanceId())
               .taskDefinitionKey(otherTaskId.getExpressionText())
               .singleResult();


Am I possibly using "historyService.createHistoricTaskInstanceQuery()" the wrong way?
If its all about the libraries that are not present in the right version, how and where can I find out about this? I have checked the lib-folder of tomcat, the projects lib-folder, activiti-explorer - but I almost believe i am looking into the wrong direction… :sorry:

Any help your be very much appreciated :)
Kind Regards!



Outcomes