AnsweredAssumed Answered

existing process data backward compatibility when upgrade from 5.7 to 5.18

Question asked by yanharry on May 17, 2016
Latest reply on May 18, 2016 by yanharry
We recently found some activiti related issues in our production, noticed that those activiti issues have been addressed in 5.10/5.11, we decide to upgrade activiti to 5.18 (our environment is weblogic/oracle 10g/activiti 5.7).

We will follow the instructions: drop the activiti new jar in our application, using DDL scripts provided in the jar to update DB from 5.7 to 5.18. But we have some concerns about our existing process data which have been created from activiti 5.7(just let you know we are heavily using activiti, everyday tens of thousands processes get created), after we upgrade our both activiti tables and libs from 5.7 to 5.18, will those existing processes have any compatible problems with new activiti libs and/or tables ? If that's possible, are there any guides we should look at?

Outcomes