AnsweredAssumed Answered

issue in mail task

Question asked by skverma02 on May 27, 2016
Latest reply on Jun 3, 2016 by jbarrez
hello sir..
when i configure mail server on my activiti-custom-context.xml and engine.properties and restart the activiti its not use  mysql database which is configure
in db.properties ? activiti run other database when i again restart its use some other database.

activiti-custom-context.xml  configuration is


<bean id="processEngineConfiguration" class="org.activiti.engine.impl.cfg.StandaloneInMemProcessEngineConfiguration">
<property name="mailServerHost" value="abc.syz.com" />
<property name="mailServerPort" value="402" />
<property name="mailServerUseSSL" value="true" />
<property name="mailServerUseTLS" value="true" />
<property name="mailServerDefaultFrom" value="saurabh.varma@gmail.com" />
<property name="mailServerUsername" value="saurabh.varma@gamil.com" />
<property name="mailServerPassword" value="xyz" />
</bean>
engine.properties for email server

email properties
engine.email.enabled=true
engine.email.host=abc.syz.com
engine.email.port=402

db.properties configuration
db=mysql
jdbc.driver=com.mysql.jdbc.Driver
jdbc.url=jdbc:mysql://localhost:3306/activiti
jdbc.username=root
jdbc.password=password

Outcomes