AnsweredAssumed Answered

Altering Database/Tables for utf8mb4

Question asked by travis.wilson on Aug 8, 2016
Latest reply on Sep 7, 2016 by travis.wilson
Hello,

I'm looking to alter activiti to use utf8mb4 instead of utf8_bin. When running the following sql command:

<sql>ALTER TABLE `activiti`.'ACT_RE_PROCDEF' CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_bin;<sql>

I get the following error: Error Code 1071. Specified key was to long; max key length is 767 bytes.

I've done a few things to get this far so heres some background:
1)Run: ALTER DATABASE `activiti` CHARACTER SET = utf8mb4 COLLATE = utf8mb4_bin;
1) SET FOREIGN_KEY_CHECKS=0;
2) SET innodb_large_prefix=ON

The only article I've found that shows a solution to this issue is: https://github.com/chaps-io/public_activity/issues/218. My only concern with this is how it it may affect the engine itself.

Questions:
Is the solution linked a possible option? If so, what are the issues that we may see?
Is there anything on your road map that may allow utf8mb4 in the future?

Thank you!

P.S. If you need further details of information just let me know.




Outcomes