AnsweredAssumed Answered

Kerberos doesn't work

Question asked by baikal on Feb 28, 2017
Latest reply on Mar 7, 2017 by baikal

So I already have one alfresco server configured with kerberos and it works just fine. Now I want a new server with the same configuration for testing purpuses. Configuration for the new test server is the same as for the old one, the only difference is two new AD user accounts AlfnewHTTP and AlfnewCIFS (here is a tutorial I followed https://community.alfresco.com/message/753714-config-alfresco-und-kerberos).

All seems to be right, /alfresco works, but I can't log in to /share, when I try to it prompts me for password for several times (with SSO enabled) which ends up with a blank page with Simple+Smart logo or (with disabled SSO) shows login page and after I enter my login and password I see "Your authentication details have not been recognized or Alfresco may not be available at this time."

 

I have following errors in my share.log (with SSO):

2017-02-28 09:59:35,861 ERROR [org.springframework.extensions.config.RemoteConfigElement] [localhost-startStop-1] java.io.FileNotFoundException: alfresco/web-extension/alfresco-system.p12 (No such file or directory)
2017-02-28 09:59:35,862 ERROR [org.springframework.extensions.config.RemoteConfigElement] [localhost-startStop-1] java.io.FileNotFoundException: alfresco/web-extension/ssl-truststore (No such file or directory)
2017-02-28 09:59:35,862 WARN [org.springframework.extensions.config.RemoteConfigElement] [localhost-startStop-1] Custom SSL socket factory was not configured, as there was no Keystore or Truststore.

(these three lines also appeare in a log on my old server, where everything works)
2017-02-28 10:03:37,742 INFO [org.alfresco.web.site.EditionInterceptor] [http-apr-80-exec-4] Unable to retrieve License information from Alfresco: 401

 

(without SSO)

2017-02-28 10:34:33,609 INFO [org.springframework.extensions.webscripts.connector.RemoteClient] [http-apr-80-exec-4] Exception calling (GET) http://localhost:8080/alfresco/s/remoteadm/has/alfresco/site-data/component-types/webscript.xml?s=sitestore
2017-02-28 10:34:33,609 INFO [org.springframework.extensions.webscripts.connector.RemoteClient] [http-apr-80-exec-4] Error status 503 Connect to localhost:8080 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused
org.apache.http.conn.HttpHostConnectException: Connect to localhost:8080 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused

 

Why localhost:8080 if my server is running on port 80?

Any suggestions?

Outcomes