AnsweredAssumed Answered

Out of Memory

Question asked by khairulsafie on Mar 27, 2017
Latest reply on Mar 30, 2017 by khairulsafie

Hi All,

 

I have an issue whereby the alfresco always hit an error as below:

Caused By:

org.alfresco.repo.search.impl.lucene.LuceneQueryParserException: 0221807994 Request failed 404 /solr/alfresco/alfresco?wt=json&fl=DBID%2Cscore&rows=2147483647&df=TEXT&start=0&locale=en_US&fq=%7B%21afts%7DAUTHORITY_FILTER_FROM_JSON&fq=%7B%21afts%7DTENANT_FILTER_FROM_JSON

 

This error will keep repeating come out for every 30 seconds (Due ot this it will cause OOM issue) and I have no ideas how to solve it since I'm not going to stop/uninstall SOLR. 

 

I have try to perform full re-index with SOLR follow this link:

Performing a full reindex with Solr | Alfresco Documentation 

Remove Solr from an Alfresco installation | Alfresco Documentation 

Not really sure by doing the above one can solve the issue or is there any better solution to this issue.

 

My findings on this issue is it will occur when the solr.xml is missing or when solr folder is deleted or missing.

 

Additional things that I have find out, after restarted the alfresco, the alfresco will take time to complete the re-indexing and it might slow the accessing on alfresco CMS. While completing the re-indexing, in alfresco log it will show the error like I have mentioned above. But this error will not appear after re-indexing completed (Not sure if it relate with re-indexing). 

 

So here, need any helps from someone in Alfresco community to give the better solution on this issue. 

 

Please advise me. Thanks.

 

Newbies to alfresco. Cheers.

Outcomes