AnsweredAssumed Answered

Problem installing Community Edition 201702

Question asked by akafortes on Apr 5, 2017
Latest reply on Jun 30, 2017 by mtsiak

Fresh install of Ubuntu Server 16.04.2 LTS

The only things that I have installed are

  1. openssh
  2. oracle JDK 8

I've downloaded "alfresco-community-installer-201702-linux-x64.bin", made it executable and run it. I get the following error:

Some or all of the libraries needed to support LibreOffice were not found on your system: fontconfig libSM libICE libXrender libXext libcups libGLU libcairo2 libgl1-mesa-glx
You are strongly advised to stop this installation and install the libraries.
For more information, see the LibreOffice documentation at http://docs.alfresco.com/search/site/all?keys=libfontconfig

Following that link I got to Installing Linux libraries manually which gives me some paths that I cannot find in my system.

I have then gone and installed LibreOffice using

sudo apt-get install libreoffice

I then run the installer again and it still gives me the same error.

 

 

I have tried installing an older version of Alfresco (Community Edition 201602) and the installation completed with no problem. (After that I reinstalled Ubuntu and started with a clean server, trying to install the new Community Edition)

Outcomes