AnsweredAssumed Answered

Problem running AIO project from SDK 3

Question asked by akafortes on Apr 6, 2017
Latest reply on Apr 12, 2017 by ohej

I have installed the Community Edition 201702 using the Ubuntu Installer, as suggested to me in a previous question I've asked (Problem installing Community Edition 201702)

Then I've created an AIO using

 

mvn archetype:generate -DarchetypeGroupId=org.alfresco.maven.archetype -DarchetypeArtifactId=alfresco-allinone-archetype -DarchetypeVersion=3.0.0 -DinteractiveMode=false -DgroupId=com.acme.alfresco -DartifactId=my-aio-project

from the Announcing Alfresco SDK 3.0 blog post. The output of the above command is in the "sdk3_aio.txt" file.

Then I cd in the folder of the created project, make the run.sh executable and then I run it.
At some point I start seeing errors like this:

 2017-04-06 10:08:00,966  ERROR [solr.tracker.AbstractTracker] [org.alfresco.solr.AlfrescoCoreAdminHandler@4795c238_Worker-1] Model tracking failed
org.alfresco.error.AlfrescoRuntimeException: 03060000 GetModelsDiff return status is 403
     at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1181)
     at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:256)
     at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:214)
     at org.alfresco.solr.tracker.ModelTracker.ensureFirstModelSync(ModelTracker.java:236)
     at org.alfresco.solr.tracker.CoreWatcherJob.registerForCore(CoreWatcherJob.java:145)
     at org.alfresco.solr.tracker.CoreWatcherJob.execute(CoreWatcherJob.java:82)
     at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
     at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

And it just continues like this(different exception numbers etc) until I just stop it with Ctrl+C. I've included the output, after I executed run.sh, in the "sdk3_run.txt"

 

Does anyone know what the problem is?
I'm trying to follow some steps from the documentation to make some custom content models and in the "Create.." menu of the Share UI and in all of the them it tells me that I have to create an AIO project first and use that.

Attachments

Outcomes