AnsweredAssumed Answered

Can't install alfresco records management community version

Question asked by attrezzo on Apr 10, 2017
Latest reply on Apr 10, 2017 by douglascrp

Ok Community Edition 201702  on a ubuntu 16.04.2 lts server. 

 

I install the OS and update, install the extra applications per How to install Alfresco Community Edition 5.1 in Ubuntu Server 14.04.

I then installed oracle-java9 for jdk (no openjdk is installed) and installed libGLU libcairo2 libgl1-mesa-glx from the apt repos to fill out the requirements.
Finally I install alfresco per the guide linked above.
Everything's great. All goes as smooth as butter....

 

So starting from a working installation:

 

I try to add record management amp. I've tried 2.5.a and 2.4.b but both come up with the same issues. 

I've tried exactly as instructed here Installing Records Management AMP files | Alfresco Documentation 
I've also tried to skip manually removing cache webapps/alfresco webapps/share instead using ./bin/apply_amps.sh and allowing it to clear up cache.

 

Like this...
service alfresco stop
cp /opt/alfsource/alfresco-rm-community-repo-2.5.a.amp /opt/alfresco/amps/

cp /opt/alfsource/alfresco-rm-community-share-2.5.a.amp /opt/alfresco/amps_share/
./opt/alfresco/bin/apply_amps.sh

 

Both ways and about a hundred other things I've tried end up with the error log you'll find attached.

Attachments

Outcomes