AnsweredAssumed Answered

Al utilizar org.alfresco.tools.import parece que funciona pero tras un tiempo el rendimiento decrece y no avanza.

Question asked by dspadial on Apr 20, 2017
Latest reply on May 2, 2017 by dspadial

#

Buenas:

Muchísimas gracias por mantener y promocionar esta herramienta.

Mi consulta:

Es que en un repositorio que esta compuesto por unos 12GB y unos 30640 archivos, utilizando la herramienta de consola org.alfresco.tools.export / org.alfresco.tools.import. En el momento de realizar la exportación todo funciona adecuadamente y tras dos horas mas o menos la exportación se realiza satisfactoriamente.

El problema surge a la hora de realizar la importación, ya que al principio. Los primeros +/-1000 registros / 40 minutos, el rendimiento es el esperado. Pero en ese instante el rendimiento decae notable y progresivamente al punto que trascurridas unas 10 horas parece detenerse en unos +6000 registros y unos 3GB completados.

He probado todo lo que en mi mano he encontrado, tunning del postgresql incrementando sus buffers y utilización de memoria, aumento y disminución de valores -XX:MaxPermSize -Xms -Xmx a la hora de iniciar java.

sin ningún tipo de éxito.

 

Estas operaciones se están realizando en Ubuntu 16.04, Alfresco 4.2.f, postgresql 9.2, indices Lucene. y el java de la instalación.

La instalación en los dos Alfrescos, el que exporta y el que importa es la misma.

 

No se me ocurre nada. indicar que desde que inicia el proceso de importación el proceso postgresql siempre esta entre el 80% y el 98% cd la CPU, pero es que en la exportación sucede lo mismo.

 

ambas maquinas están dotadas del mismo hardware que digamos lo no es escaso. 4 nucleos, 8 GB, los discos son agiles.

 

¿Que puede estar sucediendo?, ¿Como podría solucionarlo?.

Los log no indican nada o no veo nada.

 

Lo dicho muchísimas gracias y espero que alguien que tropezara en la misma piedra pudiera darme alguna pista.

 

Outcomes