AnsweredAssumed Answered

Alfresco 5.2 setting up NAS for CS and Solr4

Question asked by g_rathod on May 11, 2017
Latest reply on May 19, 2017 by g_rathod

Team,

I am facing on issue, setting up  contentStore and Solr location on NAS drive. For most of previous version upto 5.1 I am successfully configured it, but in Alfresco 5.2 (Enterprise) when I setup ContentStore location and Solr index location to NAS, alfresco starts half and did not progress ahead (catalina.out stuck at one level)

 

INFO: Deploying configuration descriptor /opt/alfresco/alfresco520/tomcat/conf/Catalina/localhost/solr4.xml
May 11, 2017 1:54:39 AM org.apache.catalina.startup.SetContextPropertiesRule begin
WARNING: [SetContextPropertiesRule]{Context} Setting property 'debug' to '0' did not find a matching property.
May 11, 2017 1:54:48 AM org.apache.catalina.core.ApplicationContext log
INFO: No Spring WebApplicationInitializer types detected on classpath

After above line it is not going ahead stuck only that location.

 

Note :

1) If I pointed solr to my default location  /opt/alfresco/alf_data/solr4   ( it works)

2) If I pointed ContentStore to NAS and solr to default path as point #1  (it works)

3) If I point ContentStore and Solr both to NAS path (it is not working)

 

Now question is if I mis-configured solr here then below are the configurations I did , let me know if I missed anything

 

Change for contentStore (alfresco-global.properties)

/opt/NASdrive/alfresco520/alf_data

 

For Solr4 (alfresco520/solr4/workspace-SpacesStore/conf/solrcore.properties)

data.dir.root=/opt/NASdrive/alfresco520/alf_data/solr4/index

 

For Solr4 (alfresco520/solr4/archive-SpacesStore/conf/solrcore.properties)

data.dir.root=/opt/NASdrive/alfresco520/alf_data/solr4/index

Tomcat ( tomcat/conf/Catalina/localhost/solr4.xml )

<?xml version="1.0" encoding="utf-8"?>
<Context debug="0" crossContext="true">
  <Environment name="solr/home"        type="java.lang.String" value="/opt/alfresco/alfresco520/solr4" override="true"/>
  <Environment name="solr/model/dir"   type="java.lang.String" value="/opt/NASdrive/alfresco520/alf_data/solr4/model" override="true"/>
  <Environment name="solr/content/dir" type="java.lang.String" value="/opt/NASdrive/alfresco520/alf_data/solr4/content" override="true"/>
</Context>

Make sure here I keep solr4 home as default not pointing to NAS.

 

Can anyone tell me what I am missing here? My point here is to move default solr location to NAS drive.

Outcomes