AnsweredAssumed Answered

Alfresco Audit Analysis Import error: Unexpected end of file from server

Question asked by michael.nadeau@roberthalf.com on May 18, 2017
Latest reply on May 25, 2017 by fcorti

Hello Everyone,

I'm new to the Alfresco Audit and Reporting plugin.  It looks like the perfect add on for our audit and reporting requirement.  Thank you Francesco!  Before I can deploy it to our production site I need to get it working in a test environment so I can demo it to my boss.  On my workstation I set up Alfresco Community - 5.2.0 (r135134-b14), Pentaho Community Ed. 7.0.0.0.25, and Postgres 9.6.2.  Java is 1.8.0_131.  OS is Windows 8.1.  HP Workstation.

 

The problem I'm having is during the extract.  I'm getting a java.net.SocketException error during the REST calls to my Alfresco.   Unexpected end of file from server.  The alfresco api and AAAR REST calls all work fine from the browser.  It is only during the extract that it is not working.  The first AlfrescoAudit file is created.  The others are all empty.

 

2017/05/18 11:54:23 - HTTP - Start of HTTP job entry.
2017/05/18 11:54:23 - HTTP - Connecting to URL: http://localhost:8088/alfresco/service/api/workflow-definitions
2017/05/18 11:56:53 - HTTP - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : I was unable to save the HTTP result to file because of a I/O error: Unexpected end of file from server

 

I've tried a couple of things but the error is always the same.  Here are some of the things I've done.

Upgraded to Java 64 bit version.  (had memory errors)

Moved default Alfresco database to installed Postgres (no difference)

In alfresco-global.properties defined db.url as jdbc:postgresql://localhost:5433/alfresco.  (imbedded properties caused REST errors)

Moved temporary folder from local to f:/Temp by setting -Djava.io.tmpdir=f:\Temp in Spoon.bat.  I tried f:\Temp and f:\Temp\ (no difference)

Changed java from jre to jdk and back to jre.  (in case of missing jar's)

 

 

 

Any ideas for further investigation would be a big help.

 

Thank you,

Mike

Attachments

Outcomes