AnsweredAssumed Answered

How to fix the error "npm ERR! Peer dep missing: @ angular ..."?

Question asked by varlok on Jun 29, 2017
Latest reply on Jun 30, 2017 by varlok

Hello everybody. Did everything according to the instructions. With the command "npm start" I receive messages:

npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.3.0, required by ng2-charts@1.5.0
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/common@^2.3.0, required by ng2-charts@1.5.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.3.0, required by ng2-charts@1.5.0
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@~2.0.0, required by ng2-translate@2.5.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/core@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/core@^2.3.0, required by ng2-charts@1.5.0
npm ERR! peer dep missing: @angular/core@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@~2.0.0, required by ng2-translate@2.5.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0
npm ERR! peer dep missing: @angular/http@^2.2.0, required by @angular/material@2.0.0-beta.1
npm ERR! peer dep missing: @angular/http@^2.0.0, required by ng2-translate@5.0.0

 

And at the end of the "build error".

What is the reason and how to fix it?##

Outcomes