AnsweredAssumed Answered

Backup d'une version antérieure

Question asked by sylvainr on Jul 4, 2017
Latest reply on Jul 6, 2017 by sylvainr

Bonjour,

 

Je vous expose ma problématique :

 

J'ai installé  et configurer un Alfresco Community Edition dans mon entreprise. J'ai effectué mes test dessus, pour explorer les différentes possibilité qu'offre Alfresco Community Edition 5.2.0. 

Tout à l'air de fonctionner correctement. Cette installation utilise une base de données postgresql installée lors de l'installation initiale. Et j'ai donc créer des utilisateurs et des sites avec des droits différents pour tester les différentes fonctionnalités proposées. 

 

En production, c'est une ancienne version d'Alfresco community edition qui tourne. Et celle-ci utilise une base de données mysql.

J'ai installé le connecteur mysql en prévision dans ma nouvelle installation en 5.2.0, puisque le but final est bien entendu de mettre en prod la nouvelle version.

 

1ère question:

J'ai donc commenté dans le fichier de conf "alfresco-global.properties" les lignes concernant la base postgresql et j'ai donc rajouté des lignes pour le connecteur mysql. J'ai redémarrer le serveur tomcat  en utilisant le script "alfresco.sh" avec la commande "restart" et je vois que au démarrage le script relance toujours la base de données postgresql.

Est-ce normal ? 

 

Maintenant, je souhaite faire un backup de la base mysql de prod, ainsi que le contentstore de l'alfresco community edition qui est en prod, de manière à restaurer se backup pour l'utiliser avec la nouvelle installation. 

 

2ème question:

J'ai aussi remarqué que l'alfresco community edition qui est en prod utilise lucene, et la nouvelle version utilise solr4,

du coup ai-je besoin de faire un backup de lucene ?

Ou est-ce que simplement restaurer le contentstore ainsi que la base de données suffira ?

 

J'espère avoir été clair au possible :/

 

Sylvain

Outcomes