AnsweredAssumed Answered

Upgrade issues from 5.0.0 to 5.2.f

Question asked by gianfi on Jul 16, 2017
Latest reply on Jul 17, 2017 by gianfi

Hello,

I'm having some issues trying to update to 5.2.f  from Alfresco Community v5.0.0 (c r91299-b145) schema 8009, on postgres DB backend.

 

I have installed Alfresco 5.2.f on a new server, migrated the alf_data folder, imported the old DB and pointed the alfresco-global.properties settings to the old DB. As my authentication backend is LDAP, i copied also my ldap subsystem config files in the correct locations.

 

At first start, migrate applies some patches to the database, then it throws out the following errors in Alfresco-PostgreSQLDialect-Validation-Post-Upgrade migration logfile:

Difference: missing index from database, expected at path: .alf_node_properties.idx_alf_nprop_b
Difference: missing index from database, expected at path: .alf_node_properties.idx_alf_nprop_d
Difference: missing index from database, expected at path: .alf_node_properties.idx_alf_nprop_f

and fails to start.

 

I have tried to manually create the missing DB indexes idx_alf_nprop_d, idx_alf_nprop_b, idx_alf_nprop_f   doing a diff from a stock alfresco 5.2.f database, without success: after restarting alfresco, the startup fails trowing out a generic error:

...

org.alfresco.error.AlfrescoRuntimeException: 06160001 Workflow deployment failed

...

Caused by: org.alfresco.error.AlfrescoRuntimeException: 06160000 Required people system path not found: sys:system

..

no other error is displayed in alfresco log.

Full alfresco.log is at : 2017-07-16 12:30:12,517 INFO [org.alfresco.repo.admin] [localhost-startStop-1] - Pastebin.com 

 

thanks for any help.

Outcomes