AnsweredAssumed Answered

Increase embedded activiti engine version

Question asked by ttrn on Aug 3, 2017
Latest reply on Aug 3, 2017 by afaust

Hello.

 

I`m new in Alfresco and I have some not very smart questions

 

I use Alfresco Community 5.2 created by alfresco-allinone-archetype and it contains embedded activiti 5.19.0.3. I think this activiti engine is bad because this version has some thread safety troubles with delegate expression fields, but hasn`t got DelegateHelper class.

 

1. Can I increase embedded activiti version to 5.22 or maybe 6.0? And how can I do it?

2. Or maybe I can use standalone activiti engine (5.22, 6.0) for developing and production?

 

Thanks.

Outcomes