AnsweredAssumed Answered

Problem enabling CORS on APS

Question asked by nickchase on Aug 2, 2017
Latest reply on Aug 4, 2017 by nickchase

I am working on my first ADF application.  I have created the template application OK using the yo tooling, I can log onto the Alfresco Content Services however I have trouble when I set the Process Services switch to on.  When I do this I get the following error message..."Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.".  I can log into the Activiti web app OK and the web app is running at 'http://127.0.0.1:9080/activiti-app' and the ADF settings are showing 'http://127.0.0.1:9080'.  I am assuming that there is a CORS issue with APS.

I am running Activiti 6.0.0 in Tomcat 7.0.79.  I have read the CORS instructions for APS, these say modify <activity>/tomcat/lib/activiti-app.properties but in my install I dont have a properties file in this location; the properties file is in <activity>/tomcat/webapps/activiti-app/WEB-INF/classes/META-INF/activiti-app/activiti-app.properties.

I have added the following lines to the above file and changed the admin password to the same as the admin password in Alfresco (lines added are cors.enabled=true, security.csrf.disabled=true).  I have then restarted the Activit tomcat instance, I can now login at the Activiti app with admin/admin so I belived the changes in the file have been read, but when I login to the ADF app I still get the same error described above.  I have also created an activiti-app.properties file in <activiti>/tomcat/lib and placed the CORS lines in this file but it does not change anything.

 

I really love the idea of ADF and belive we can create much better applications around Alfresco/Activiti in this way, before ADF creating custom applications took a long time.

Outcomes