AnsweredAssumed Answered

Got different alfresco archetype version (shell prompt vs IDE)

Question asked by billydekid on Aug 12, 2017
Latest reply on Aug 14, 2017 by billydekid

Hi,

Just curious on alfresco archetype version when creating new alfresco applications/extensions.

For example, I want to create a new alfresco-platform-jar-archetype extension.

 

If I created from shell prompt, the options version permission are: 3.0.0 and 3.0.1

But, when I create new project (I use eclipse IDE), it will get to single/default latest version 3.0.0-beta-5. As we know it comes from archetype catalog at https://nexus.alfresco.com/nexus/content/groups/public/archetype-catalog.xml 

 

<archetype>
<groupId>org.alfresco.maven.archetype</groupId>
<artifactId>alfresco-platform-jar-archetype</artifactId>
<version>3.0.0-beta-5</version>
<repository>
https://maven.alfresco.com/nexus/content/groups/public
</repository>
<description>
Sample project with full support for lifecycle and rapid development of Platform/Repository JARs and AMPs (Alfresco Module Packages)
</description>
</archetype>

 

How the shell prompt could get the latest version of archetype while the "official" still on 3.0.0-beta-5 ?

 

Thanks,

[bayu]

Outcomes