AnsweredAssumed Answered

Alfresco lenteur(s)

Question asked by mamatov86 on Sep 27, 2017
Latest reply on Nov 2, 2017 by mamatov86

  Bonjour,

 

Je viens d'installer alfresco community 5.2 (Community - 5.2.0 (re21f2be5-b22) sur cet environnement :

 

VM (sous VMware) :

  • OS : Centos 7
  • RAM : 8 Go
  • CPU : 2 Vcpu  2.6 GHz

 

Alfresco Composants

  • Java
  • PostgreSQL
  • LibreOffice
  • Alfresco Content Services
  • Solr 4
  • Olfresco Office Services
  • Web Quick Start
  • Google Docs Integration

 

Java (/opt/alfresco-community/tomcat/bin/setenv.sh)

  • Xms : 4Go
  • Xmx : 4Go

 

Nginx : reverse proxy pour gérer le SSL

 

Je précise que c'est une plateforme de test avant une mise en production. Aucun utilisateur n'utilise Alfresco pour le moment.

 

Quand Alfresco démarre, j'ai remarqué une forte consommation du process Java (mes deux CPU étaient utilisés à 100%)

Au bout de 30 secondes environ la charge redevient normal.

 

Je lance une connexion sur https://mondomaine/share :

 

  • La page d'authentification arrive après 30 secondes
  • Je rentre mes identifiants et je dois encore attendre 30 secondes avant d'arriver sur mon dashboard
  • Je me déconnecte de la session, je rentre à nouveau mes identifiants et j'accède ensuite au mon dashboard instantanément.

 

=> Les lenteurs de connexion sont présente après un redémarrage de Alfresco. Est-ce que c'est normal ?

Si oui, c'est assez gênant car je compte faire chaque nuit une sauvegarde à froid et donc un redémarrage.

Je me demandais si on pouvait améliorer cela.

 

Une dernière chose, sans rien faire sur Alfresco, j'ai remarqué que le process Java prenait entre 20 et 50 % d'utilisation d'un coeur CPU en permanence. Est-ce que c'est un comportement normal ?

 

Merci d'avance pour vos réponses et vos conseils.

Outcomes