AnsweredAssumed Answered

How to make SSO work?

Question asked by janmussche on Oct 9, 2017
Latest reply on Oct 14, 2017 by mehe

Hi all,

 

I've been working in setting up Alfresco for the last 3 weeks and although the program itself works fine, I can not get SSO to work. The situation is like this:

We have a Windows AD where everyone in our company is situated.

I have installed the Community Edition onto a Ubuntu 16.04 server in a virtual machine, using this installation file: alfresco-community-installer-201707-linux-x64.bin.

I can login as administrator on the webpage and do all necessary things. Login with my own credentials, located in the AD work. In other words the credentials stored in the AD are used. There are no local users in Alfresco.

 

What we want is an SSO where everyone logged in to his computer with the AD credentials automatically will be logged in to the webpage without having to type his name and password again. We don't want to see the Alfresco login page.

 

As I wrote I have been working on this for several weeks already, reading a 1001 webpages, both the Alfresco documentation pages as well as foreign pages where people write they managed to do this. Everywhere the info is different and whatever I try, it doesn't work.

 

Can somebody here please explain in a step-by-step way what I need to do after having installed Alfresco to make SSO work? Don't point me to webpages for info please, I have seen too many of those already, just tell me here:

step 1:   this

step 2:    that

and so on.

I know I am asking alot but after working all these weeks and still not having success I need help.

 

What do I need to do, both in Alfresco and in the AD to make it work? Please help.

 

Thank you for your understanding and help.

 

Jan.

Outcomes