AnsweredAssumed Answered

Unable to upload file in alfresco via cifs on a folder which has rule applied in it.

Question asked by manav on Nov 9, 2017
Latest reply on Nov 10, 2017 by afaust

Hi everyone,

 

I am using alfresco community 5.2 and windows 10. My requirement is to save document directly in alfresco by doing Save As from any windows application and rename it on the basis of certain criteria. To satisfy this, I have create a rule to execute a script that will rename the document when it is created in folder. And also enabled CIFS in alfresco and mapped it as network drive. But when I try to save my document to that folder it giving error "You don’t have permission to modify files in this network location.Contact the administrator per permission to make these changes."

 

To debug my problem I tried by uploading the document directly from alfresco share and It is getting renamed successfully.

I also tried by disabling rule on the folder then saved the document from windows and it is getting saved in alfresco.

 

And again if I enable my rule, it is giving the same permission error.

 

I have attached screenshot of my problem and the test script created by me just to test rename.

 

It is appreciable if anyone would help me to solve this problem.

Attachments

Outcomes