AnsweredAssumed Answered

Alfresco custom role (permission) is not working as expected with 5.2.0

Question asked by vishal.zanzrukia on Nov 30, 2017
Latest reply on Dec 7, 2017 by andy1

I am using alfresco-content-services 5.2.0 enterprise version.

I have defined my custom role CUSTOM_DELETE something like below, here custom:baseAspect is my custom aspect.

 

<permissionSet type="custom:baseAspect" expose="selected">

<permissionGroup name="CUSTOM_DELETE_Permission" expose="false" allowFullControl="false"/><permissionGroup name="CUSTOM_DELETE" allowFullControl="false" expose="true">


<includePermissionGroup type="custom:baseAspect" permissionGroup="CUSTOM_DELETE_Permission" />
<includePermissionGroup type="sys:base" permissionGroup="Read" />
<includePermissionGroup type="sys:base" permissionGroup="WriteProperties"/>
<includePermissionGroup type="sys:base" permissionGroup="Delete"/>

 

</permissionGroup>

 

<permission name="_CUSTOM_DELETE_Permission" expose="false">
            <grantedToGroup permissionGroup="CUSTOM_DELETE_Permission"/>
</permission>

</permissionSet>

Given :

I am creating any content which is having aspect (custom:baseAspect) under public site with assigning permission like this

NODE_1 : CUSTOM_DELETE : GROUP_1

Expected Behavior :

Now if I login with user which under GROUP_1, he/she should be able to Read content, Write/Edit Properties and Deletethe content.

Actual Behavior :

User is able to Read content, Delete content but not able to Write/Edit properties.

Am I doing something wrong?

Regards, Vishal Z.

Outcomes