AnsweredAssumed Answered

Activiti-rest not connecting to db

Question asked by laurav on Dec 4, 2017
Latest reply on Dec 7, 2017 by laurav

Hi,

 

I am running activiti 6.0.0. 

I have no problem using activiti-app with my oracle database and the tables get updated as expected.

However, using activiti-rest (with the same database settings) doesn't seem to work.

 

I can log in with the kermit demo user but not with any real user. I changed the create.demo.users to false but this locks me out completely (404) so it seems that it is not connecting to my database.

create.demo.users=false

create.demo.definitions=false

create.demo.models=false

 

Here are the rest of the engine.properties settings

# engine properties

engine.schema.update=true

engine.activate.jobexecutor=true

engine.asyncexecutor.enabled=true

engine.asyncexecutor.activate=true

engine.history.level=full

 

Here is my db.properties :

db=oracle

jdbc.driver=oracle.jdbc.driver.OracleDriver

jdbc.url=jdbc:oracle:thin@localhost:1521:XE

jdbc.username=activiti

jdbc.password=pwd

 

 

and here is my activiti-app.properties:

 

datasource.driver=oracle.jdbc.driver.OracleDriver

datasource.url=jdbc:oracle:thin:@localhost:1521:XE

datasource.username=activiti

datasource.password=pwd

 

Any help appreciated,

 

Outcomes