AnsweredAssumed Answered

alfresco-5.0.b - WQS unable to connect to repository: Not Found

Question asked by rocklee44 on Jan 4, 2018
Latest reply on Jan 9, 2018 by rocklee44

Hi all,

This is my Alfresco ECM production environment :

OS : Centos 6.4

Alfresco community 5.0.b (installed all in one step - alfresco-community-5.0.b-installer-linux-x64.bin) at /opt/alfresco-5.0.b

Database : mysql-server-5.1.73-8.el6_8.x86_64

/opt/alfresco-5.0.b/tomcat/shared/classes/alfresco-global.properties

dir.root=/opt/alfresco-5.0.b/alf_data
dir.contentstore=/opt/contentstore

The production is running normally.

Backup steps running at night :

- mysqldump database "alfresco"

- backup all directories /opt/alfresco-5.0.b and /opt/contentstore .

 

I attempt to update my ECM to latest version 201707 (community) so I want to test it first :

- I build a test Centos 6.4 server with mysql-server-5.1.73-8.el6_8.x86_64 as above

- Import a full dump of "alfresco" db into clone server

- clone directory /opt/alfresco-5.0.b from production server to test server by scp

- create /opt/contentstore on test server without data

After starting mysqld and alfresco on test server I cannot login to http://myecm/share , this is output of catalina.out :

2018-01-04 17:36:00,067  ERROR [solr.tracker.AbstractTracker] [SolrTrackerScheduler_Worker-1] Tracking failed
 org.alfresco.error.AlfrescoRuntimeException: 00040421 GetModelsDiff return status is 404
        at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1095)
        at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:245)
        at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:207)
        at org.alfresco.solr.tracker.ModelTracker.doTrack(ModelTracker.java:167)
        at org.alfresco.solr.tracker.AbstractTracker.track(AbstractTracker.java:155)
        at org.alfresco.solr.tracker.TrackerJob.execute(TrackerJob.java:47)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)
17:36:00,652 WARN  [org.alfresco.wcm.client.util.impl.GuestSessionFactoryImpl] WQS unable to connect to repository: Not Found
17:36:02,657 WARN  [org.alfresco.wcm.client.util.impl.GuestSessionFactoryImpl] WQS unable to connect to repository: Not Found

My intention is trying to upgrade ECM on test server from 5.0.b to latest version first, then do it on production server but it seems my restoration doesn't work or my backup steps was wrong or I did something wrong ?

Please give me some advice, thank you very much.

Outcomes