AnsweredAssumed Answered

Publish to Alfresco Task not work in Alfresco install in Windows Spanish

Question asked by fegor on Jan 11, 2018
Latest reply on Feb 15, 2018 by fegor

Hello!

 

Environment of work:

Activiti Enterprise 1.5 in Windows (Spanish installation)

Alfresco One 5.1 in Windows (Spanish installation)

 

When I retrieve folders and files from site has produced an error.

 

Retrieve sites is fine:

 

 

But if choice a site:

 

 

In Chrome:

 

 

I activated Activiti logs and...

 

2018-01-10 11:57:25,678 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.atompub.CmisAtomPubSpi] [http-nio-9080-exec-8] Initializing AtomPub SPI...
2018-01-10 11:57:25,744 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.http.DefaultHttpInvoker] [http-nio-9080-exec-8] GET http://localhost:8080/alfresco/api/-default-/public/cmis/versions/1.0/atom?repositoryId=-default-
2018-01-10 11:57:26,077 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.http.DefaultHttpInvoker] [http-nio-9080-exec-8] GET http://localhost:8080/alfresco/api/-default-/public/cmis/versions/1.0/atom/path?path=%2FSites%2Forganos-de-gobierno-scefc&filter=cmis%3AbaseTypeId%2Ccmis%3AcontentStreamLength%2Ccmis%3AcontentStreamMimeType%2Ccmis%3AlastModificationDate%2Ccmis%3AlastModifiedBy%2Ccmis%3Aname%2Ccmis%3AobjectId%2Ccmis%3AobjectTypeId%2Ccmis%3AversionSeriesId&includeAllowableActions=false&includeACL=false&includePolicyIds=false&includeRelationships=none&renditionFilter=cmis%3Anone
2018-01-10 11:57:26,100 DEBUG [org.springframework.web.servlet.mvc.method.annotation.ExceptionHandlerExceptionResolver] [http-nio-9080-exec-8] Resolving exception from handler [public com.activiti.model.common.ResultListDataRepresentation com.activiti.rest.runtime.integration.AlfrescoOnPremResource.getContentInSite(java.lang.String,java.lang.String)]: com.activiti.service.exception.BadRequestException: Error while getting site content

 

I test URL and I think this is the error:

 

 

If I change Sites for Sitios then work fine!

 

Then, possible cause: Activiti not use Sites/Sitios/... for Alfresco language.

 

Is there any way easy to change this in Activiti?

 

Note: Even if Alfresco is installed with the English installer, in a Windows in Spanish it always creates the sites as "Sitios".

 

Regards,

fegor

Outcomes