AnsweredAssumed Answered

Not able to run the amps of antivirus action in alfresco

Question asked by ayushi.agrahari on Jan 22, 2018

Hi,

 

I am using Antivirus  for scanning of files for antivirus using clamav in alfresco.

 

It is running perfectly as a standalone project but when I have applied the amps using apply_amps.sh script on alfresco installation and inside AntivirusActionExecuter.java when the statement result=command.execute(properties) is executing,I have inserted the logger for printing the value of result as logger.debug(result),I have found that clamdscan command is not running correctly and is giving the following logs output 

 

os : Linux

Command:  clamdscan /usr/bin/clamdscan "home/alfresco_installation/antivirus/tomcat/temp/Alfresco/anti_virus_check3735457321432241215"

succeeded:true

exit code:127

err: /usr/bin/clamdscan: relocation error: /usr/bin/clamdscan: symbol EVP_MD_CTX_destroy, version OPENSSL_1.0.0 not defined in file libcrypto.so.1.0.0 with link time reference

 

I have tried by upgrading and updating the openssl but with no luck.Also I have tried by putting export LD_Library_Path="" in setenv.sh script of tomcat but the above error still persists.

I am unable to figure out why the standalone project is running fine but the amps doesn't

 

Any help would be highly appreciated.

Outcomes