AnsweredAssumed Answered

Https login fails on shared but work perfectly for the /alfresco admin and IOS app

Question asked by cpn on Mar 31, 2018

I am writing for help as I literally spent the last 24 hours trying to trouble shoot my install.

I started with a clean install from G.Cloud bitnami Alfresco which worked perfectly. 
I uploaded 3 GB of documents, created users and workflows.. everything great.

I then tried to install HTTPS/SSL by following the instructions in the Bitnami Alfresco Documentation: Fail. 
I thought I would master the beast by using Certbot: Big mistake:, that screwed up my install and I ended-up with the default debian index pages when calling up the url of the server.

Finally I used the Lego client. That worked! but... http requests are being rejected and port 80 remains closed.

https site works for IOS app access and /alfresco admin site but impossible to login to the /shared.

The Catalina log: multiple Connection refused paragraphs starting with: 
webscripts.connector.RemoteClient] [ajp-apr-8009-exec-4] Error status 503 Connect to localhost:80 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused

Netstat shows the following active ports: 22, 8100, 3306, 22, 443, 8443, 8005, 1445, 2025, 2121, 8009, 8080, and 1139.

I tried to modify server.xml from 8080 to 80 but catalina logs show that the port is already in use when tomcat starts up.

The SSL keys are installed in apache2 and work perfectly.
I don't need ssl activated in tomcat.
but I am not sure of the correct parameters in server.xml...

Any help would be greatly appreciated.

Benjamin

Outcomes