AnsweredAssumed Answered

How does Libreoffice start up?

Question asked by sistemi@yacme.com on May 29, 2018
Latest reply on May 29, 2018 by cesarista

Hello everybody, I am trying to get some informations about Libreoffice startup in Alfresco Community 201707 (last stable release).

 

Today I noticed that document preview was not working anymore, so I searched for libreoffice/soffice process; I found that was in <defunct> state, so i killed it. To start it again, I run ./alfresco.sh start libreoffice as alfresco user, but that command gave no output; searching in that script I found that libreoffice start script name was wrong: in the script it is named $INSTALLDIR/libreoffice/scripts/ctl.sh, but on the filesystem its name is $INSTALLDIR/libreoffice/scripts/libreoffice_ctl.sh. Searching in this forum I found some references about this typo in various old posts, so I edited alfresco.sh script and run again ./alfresco.sh start libreoffice: libreoffice started (to be honest two processes started: a running one and a <defunct> one), but file preview kept on not working.

So I decided to restart completely alfresco with ./alfresco.sh stop and start, and after that three libreoffice processes were running: a <defunct> one, and two .soffice.bin running at the same time: one had more parameters than the other one. So I re-edited alfresco.sh restoring ctl.sh as libreoffice start script and restarted again Alfresco, and this time only one process was running (the one with more parameters) and the document preview worked again.

In conclusion... I suppose that Libreoffice is not started by alfresco.sh anymore, and this is achieved by specifing a wrong script name in the script?

How is Libreoffice started in the newer versions of Alfresco? Is there a way to start it manually without restarting all Alfresco services?

Outcomes