AnsweredAssumed Answered

Activiti6 use spring-boot-starter-web meet requestMappingHandlerMapping error

Question asked by slarkchen1 on Jun 29, 2018
Latest reply on Jul 4, 2018 by slarkchen1

I get some reply from other site, the spring-boot team think activiti 6 is not compatible with spring-boot 2.0.

Cause activit 6 released in 26 May 2017. The integrated spring-boot version must be older one. 

So, Maybe i can:

1) Use early version of activiti + spring-boot

2) Use activiti 6 + spring-boot 2.0 but try to use early version of starter-web

3) Try to use activiti 7, but activiti 7 seems a different way to use from the early version of activiti.

---------------------------

 

Hello everyone.

I meet trouble with Activiti 6 and spring-boot-starter-web.

Env:

  1. Activiti 6.0.0
  2. Spring-boot 2.0
  3. Windows 10 64Bit

Here is my codes: https://github.com/cybfly/activiti-demo

Question is, activiti6 works fine with spring-boot-starter-basic,

but if i add spring-boot-starter-web in my pom.xml, i meet with this error:

 

org.springframework.beans.factory.BeanCreationException:
Error creating bean with name 'requestMappingHandlerMapping' defined in class path resource
[org/springframework/boot/autoconfigure/web/servlet/WebMvcAutoConfiguration$EnableWebMvcConfiguration.class]:
Invocation of init method failed;
nested exception is java.lang.ArrayStoreException: sun.reflect.annotation.TypeNotPresentExceptionProxy

Outcomes